icon [Homebrew]実行エラー (2016/06/17)
久々にbrewコマンドを叩いたらエラー
$ brew update
/Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- mach (LoadError)
	from /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /usr/local/Library/Homebrew/extend/pathname.rb:2:in `<top (required)>'
	from /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /usr/local/Library/Homebrew/global.rb:3:in `<top (required)>'
	from /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /usr/local/Library/brew.rb:16:in `<main>'

アクセス権の問題か?ここを参考に再構築

Gitコマンドでリセット

git reset --hard && git clean -df

/usr/local の権限を変更

自分権限、adminグループで再帰的に変更
sudo chown -R $(whoami):admin /usr/local

これで brew update できました。